Why Does Automatic Node Pool Scaling Fail in a CCE Cluster?
Symptom
When multiple nodes in a cluster become unavailable, the auto scaling function of the CCE Cluster Autoscaler add-on may stop working, preventing new containers from being scheduled.
In Kubernetes events, a ClusterUnhealthy event appears in the cluster-autoscaler-status ConfigMap.

Possible Cause
CCE Cluster Autoscaler stops scaling when the number of unavailable nodes exceeds the value of ok-total-unready-count (default: 3) and the percentage of unavailable nodes exceeds the value of max-total-unready-percentage (default: 45).
| Parameter | Description | Default Value |
|---|---|---|
| max-total-unready-percentage | Maximum percentage of unready nodes allowed in a cluster. If exceeded, CCE Cluster Autoscaler stops scaling. | 45 |
| ok-total-unready-count | Maximum number of unready nodes allowed in a cluster, regardless of percentage. | 3 |
- Example 1: If four nodes are unavailable out of six total, the percentage of unavailable nodes is 66.67%.
If the number of unavailable nodes is greater than the value of ok-total-unready-count (3) and their percentage exceeds the value of max-total-unready-percentage (45%), CCE Cluster Autoscaler will stop scaling.
- Example 2: If three nodes are unavailable out of five total, the percentage of unavailable nodes is 60%.
If the number of unavailable nodes is less than or equal to the value of ok-total-unready-count (3), their percentage exceeds the value of max-total-unready-percentage (45%), and the scale-out conditions are met, CCE Cluster Autoscaler will add two more nodes, increasing the total to seven.
Fault Locating
- Log in to the CCE console.
- Check the number of available nodes and the total number of nodes.

- Click the cluster name to access the cluster console. In the navigation pane, choose Add-ons. In the right pane, locate CCE Cluster Autoscaler.
- Click View Details, switch to the Pods tab, select a pod, and choose More > View YAML.
- Check the configuration of spec.containers.command. If ok-total-unready-count and max-total-unready-percentage are not configured, their default values are used.

Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot