Mounting a File System Fails
Symptom
When running the mount command to mount the file system to the ECSs, the message access denied is displayed.
Possible Causes
- Cause 1: The file system has been deleted.
- Cause 2: The ECS on which the mount command is executed and the mounted file system are not in the same VPC.
- Cause 3: The mount point in the mount command is incorrect.
- Cause 4: The IP address used for accessing SFS is a virtual IP address.
Fault Diagnosis
Take troubleshooting measures based on possible causes.
Solution
- Cause 1: The file system has been deleted.
- Cause 2: The ECS on which the mount command is executed and the mounted file system are not in the same VPC.
Log in to the management console and check whether the ECS and the file system belong to the same VPC.
- If yes, go to Cause 3.
- If no, re-select the file system of the same VPC as the ECS.
- Cause 3: The mount point in the mount command is incorrect.
- Log in to the management console and check whether the mount point is the same as the one in the mount command.
- If the mount point in the mount command is incorrectly entered, correct it and run the command again.
- Cause 4: The IP address used for accessing SFS is a virtual IP address.
Log in to the ECS, run the ping command and use the IP address of the ECS to access SFS. Check whether the service is reachable. See Figure 1.
- If yes, the network problem has been resolved. Check other possible causes.
- If no, the ECS virtual IP address is unable to access SFS due to the network problem. Use the private IP address and run the ping command to access SFS and check whether the service is reachable.
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