ALM-24003 Flume Client Connection Interrupted (For MRS 2.x or Earlier)
Description
The alarm module monitors the port connection status on the Flume server. This alarm is generated if the Flume server fails to receive a connection message from the Flume client in 3 consecutive minutes.
This alarm is cleared after the Flume server receives a connection message from the Flume client.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
24003 |
Major |
Yes |
Parameters
Parameter |
Description |
---|---|
ClientIP |
Specifies the IP address of the Flume client. |
ServerIP |
Specifies the IP address of the Flume server. |
ServerPort |
Specifies the port on the Flume server. |
Impact on the System
The communication between the Flume client and server fails. The Flume client cannot send data to the Flume server.
Possible Causes
- The network between the Flume client and server is faulty.
- The Flume client's process is abnormal.
- The Flume client is incorrectly configured.
Procedure
- Check the network between the Flume client and server.
- Check whether the Flume client's process is normal.
- Check the Flume client configuration.
- Log in to the host where the alarmed Flume client resides. Run the following command to switch to user root:
sudo su - root
- Run the cd Flume installation directory/fusioninsight-flume-1.6.0/conf/ command to go to Flume's configuration directory.
- Run the cat properties.properties command to query the current configuration file of the Flume client.
- Check whether the properties.properties file is correctly configured according to the configuration description of the Flume agent.
- Modify the properties.properties configuration file.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
- Log in to the host where the alarmed Flume client resides. Run the following command to switch to user root:
- Collect fault information.
- On MRS Manager, choose .
- Contact the O&M engineers and send the collected logs.
Related Information
N/A
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