ALM-47001 MemArtsCC Service Unavailable
This section is available for MRS 3.3.1 or later version only.
Alarm Description
The system checks the status of the ZooKeeper service on which the MemArtsCC depends every 60 seconds. This alarm is generated when the ZooKeeper service is unavailable.
This alarm is automatically cleared when the ZooKeeper service is normal.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
47001 |
Critical |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The service will be unavailable.
Possible Causes
The ZooKeeper service on which the MemArtCC service depends is unavailable.
Handling Procedure
Handling ZooKeeper exceptions
- Log in to FusionInsight Manager and choose O&M > Alarm > Alarms. On the ZooKeeper dashboard page, check whether the ZooKeeper service is faulty.
- Rectify the ZooKeeper fault based on the error information and alarm information and the ZooKeeper help document.
- After the ZooKeeper service becomes normal, wait for 60 seconds and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select MemArtsCC for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and send the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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