ALM-44000 Presto Service Unavailable
Alarm Description
The system checks the Presto service status every 60 seconds. This alarm is generated when the system detects that Presto is unavailable.
This alarm is cleared when the Presto service recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
44000 |
Critical |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
ServiceName |
Specifies the service for which the alarm was generated. |
RoleName |
Specifies the role for which the alarm was generated. |
HostName |
Specifies the host for which the alarm was generated. |
Impact on the System
Presto cannot run SQL queries.
Possible Causes
- The Presto coordinator or worker process is faulty.
- The network communication between Presto coordinator and worker instances is interrupted.
Handling Procedure
- Check the status of the coordinator and worker processes.
- Log in to FusionInsight Manager and choose Cluster > Services > Presto. On the page that is displayed, click the Instance tab. In the Presto instance list, check whether the status of all coordinator or worker instances is Unknown.
- In the upper part of the Presto instance list, choose More > Restart Service to restart the coordinator and worker processes.
- In the alarm list, check whether ALM-44000 Presto Service Unavailable is cleared.
- Collect fault information.
- On FusionInsight Manager, choose System > Export Log.
- Select Presto for Service.
- Click in the upper right corner.
Set Start Time and End Time for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click OK.
- Contact the O&M engineers and send the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot