ALM-50207 Ratio of Connections to the FE MySQL Port to the Maximum Connections Allowed Exceeds the Threshold
Alarm Description
The system checks the number of MySQL port connections every 30 seconds. This alarm is generated when the ratio of the number of current connections to the maximum number of FE port connections exceeds the threshold (95% by default). The maximum number of FE port connections in the current cluster is specified by the qe_max_connection parameter. The default value is 1024.
This alarm is cleared when the number of MySQL port connections on the FE node is less than or equal to the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
50207 |
Minor |
Quality of service |
Doris |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Detail |
Specifies the alarm triggering condition. |
Impact on the System
The FE is overloaded. The FE processes client requests slowly.
Possible Causes
- After the MySQL client is connected to Doris, the connection is not closed.
- A large number of services are concurrently connected to Doris.
Handling Procedure
Check whether the alarm threshold or alarm trigger count is properly configured.
- Log in to FusionInsight Manager, choose O&M, and click Alarm > Thresholds in the navigation pane on the left. Click the name of the desired cluster > Doris > Connection > FE MySQL Port Connections (FE).
- Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
- Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
If there are a large number of connections, ensure there are only necessary connections. Otherwise, the service performance may be degraded or even the service may be unavailable.
- Wait for 2 minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, select Doris for the target cluster, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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