ALM-45596 Procedure Execution Failed
Alarm Description
Procedures are the tasks managed and executed by the ConfigNode leader. This alarm is generated when a procedure fails to be executed. This alarm is cleared when the procedure is successfully executed.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45596 |
Major |
Error handling |
IoTDB |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
ProcedureInformation |
Specifies the procedure-related information. |
Impact on the System
Functions associated with the procedure are adversely affected.
Possible Causes
- The task for adding IoTDB replicas fails to be executed.
- The task for deleting the storage group fails to be executed.
Handling Procedure
- On FusionInsight Manager, choose O&M > Alarm > Alarms, locate this alarm, and click .
- Check the value of ProcedureInformation in Location. The value starts with the procedure type and contains main information about the procedure.
Check whether the task for adding replicas fails.
- Check whether the value of ProcedureInformation starts with AddRegionProcedure or ReJoinDataNodeProcedure.
- Wait for half an hour. If the region is successfully added, the alarm is automatically cleared. Otherwise, go to 5.
Check whether the task for deleting the storage group fails.
- Check whether the value of ProcedureInformation starts with DeleteStorageGroupProcedure.
- Delete the storage group displayed in ProcedureInformation again on the IoTDB client. If the deletion is successful, the alarm is automatically cleared. Otherwise, go to 7.
Collect fault information.
- Choose Cluster > Services > IoTDB > Instance to view the hosts where all IoTDBServer and ConfigNode instances are located.
- Choose O&M > Log > Download.
- Expand the Service drop-down list, select IoTDB for the target cluster, and click OK.
- Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the host queried in 7, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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