ALM-43609 TaskManager of GraphBase Is Faulty
Alarm Description
The system checks TaskManager service of GraphBase every 30 seconds. This alarm is generated when the TaskManager service of GraphBase is abnormal during the HA health check.
This alarm is cleared when the TaskManager service of GraphBase becomes normal during the HA health check.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
43609 |
Major |
Error handling |
GraphBase |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- The active and standby LoadBalancers of GraphBase may be switched over.
- The GraphBase service may be unavailable.
Possible Causes
The Tomcat service is abnormal.
Handling Procedure
Check whether the node where GraphBase locates is normal.
- On FusionInsight Manager, select the alarm whose ID is 43609, and view the IP address of the instance in location information.
- Log in to the node for which the alarm is generated as user root.
- Go to the ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/ha/module/hacom/script/ directory and run the sh status_ha.sh script to check whether TaskManager of the active Manager is normal. Specifically, check whether the following information is displayed in the line where ResName of the active management node is taskmanager:
The following are two examples:
taskmanager Normal Normal Single_active
- Contact the network administrator to check whether the network is faulty.
- Wait for 5 minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- In the Service area, select the following nodes of the desired cluster.
- If the fault is caused by GraphBase, select GraphBase.
- If the fault is caused by services on which GraphBase depends, select the faulty services and the GraphBase service. (The corresponding hosts are automatically selected once you select the services.)
- Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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