ALM-12063 Unavailable Disk
Alarm Description
The system checks whether the data disk of the current host is available at the top of each hour. The system creates files, writes files, and deletes files in the mount directory of the disk. If the operations fail, the alarm is generated. If the operations succeed, the disk is available, and the alarm is cleared.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
12063 |
Major |
Physical resource |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the name of the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Partition mount point |
Specifies the disk partition for which the alarm is generated. |
|
Additional Information |
Disk serial number |
Specifies the serial number of the disk for which the alarm is generated. |
Impact on the System
Service failure: If you need to modify or use data on a disk that is unwritable or unreadable, the job may fail.
Possible Causes
- The permission of the disk mount directory is abnormal.
- There are disk bad sectors.
Handling Procedure
Check whether the permission of the disk mount directory is normal.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and view the IP address of the host and DiskName for the disk for which the alarm is generated.
- Log in to the host where the alarm is generated as user root.
- Run the df -h |grep DiskName command to obtain the mount point and check whether the permission of the mount directory is unwritable or unreadable.
- Modify the directory permission.
- One hour later, check whether this alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 6.
- Contact hardware engineers to rectify the disk.
- One hour later, check whether this alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 8.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Select NodeAgent from the Service and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected log information.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
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