Help Center/ Server Migration Service/ FAQs/ Known Errors and Solutions/ SMS.5113 Check %s on Linux Timed Out
Updated on 2024-11-29 GMT+08:00

SMS.5113 Check %s on Linux Timed Out

Symptom

The Agent failed to be started on Linux, and the error message "Error. SMS.5113 Check %s on Linux timed out" was displayed.

Possible Causes

The execution of some commands takes a long time in the migration feasibility check stage. You can resolve the issue based on the specific check item.

Solution

  1. Go to the ...SMS-Agent/agent/linux/resources/shell directory and run the precheck script. xxx indicates the check item for which the error is reported.

    ./pre_check.sh check_<xxx>

  2. Perform operations based on the running time and result.

    • If the running time is less than 30 seconds and no error is reported, run the Agent again.
    • If the running time is longer than 30 seconds and no error is reported, edit the pre_check.sh file and add the involved check item to the end of exclude_items to exclude the check item. Then run the Agent again.
    • If no response or error is returned for a long time, some commands for the check item experience errors. For example, df -TH for check item check_df_resultmay hang if there are unresponsive external storage devices. You need to check each command involved in the check item based on the instructions below.
      1. Open the pre_check.sh file and search for check_xxx. xxx represents the check item for which the error is reported.
      2. Manually run the commands involved in the check item one by one to locate the command that causes the error.
      3. Rectify the command issue and run the Agent again.