Help Center/ Migration Center/ FAQs/ Network Settings/ What Can I Do If a Source Server Fails the Migration Readiness Check Because Delivering Commands to Edge Fails?
Updated on 2024-10-21 GMT+08:00

What Can I Do If a Source Server Fails the Migration Readiness Check Because Delivering Commands to Edge Fails?

Symptom

A Windows source server fails the migration readiness check, and a message is displayed, indicating that the command fails to be delivered to Edge.

Possible Causes

The possible causes are:

  • The provided access IP address is incorrect.
  • The source server is stopped.
  • The IP address or port of the source server is abnormal.

You can review the error cause in error log file on Edge. The error log file is stored in C:\Edge\logs\edge-server\error.log.

Solution

  1. Check whether the access IP address configured for performing the migration readiness check is correct. Ensure that Edge can connect to the source server through the provided IP address and port.

    • If the address is incorrect, correct it and try again.
    • If the address is correct, go to step 2.

  2. Check whether the source server is stopped.

    • If it is, start the source server and try again.
    • If it is not, go to step 3.

  3. On the server where Edge is installed, open the CLI and run the telnet command to check whether the port (for example, port 5985) of the source server is accessible. The command format is telnet {IP address of the source server} {Port}.

    • If the port is reachable, go to step 4.
    • If the port is unreachable, check whether the security group of the source server allows access from the public IP address of the server with Edge installed over TCP on port 5985 and over ICMP on any port. If the security group is correctly configured, perform the migration readiness check again.

  4. Check whether the access is blocked by the firewall or antivirus software on the source server. If it is, disable or adjust the blocking rule and try again.