Help Center/
Data Lake Insight/
FAQs/
SQL Jobs/
SQL Job O&M/
Why Is Error "UQUERY_CONNECTOR_0001:Invoke DLI service api failed" Reported in the Job Log When I Use CDM to Migrate Data to DLI?
Updated on 2024-11-15 GMT+08:00
Why Is Error "UQUERY_CONNECTOR_0001:Invoke DLI service api failed" Reported in the Job Log When I Use CDM to Migrate Data to DLI?
Symptom
After the migration job is submitted, the following error information is displayed in the log:
org.apache.sqoop.common.SqoopException: UQUERY_CONNECTOR_0001:Invoke DLI service api failed, failed reason is %s. at org.apache.sqoop.connector.uquery.intf.impl.UQueryWriter.close(UQueryWriter.java:42) at org.apache.sqoop.connector.uquery.processor.Dataconsumer.run(Dataconsumer.java:217) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)
Possible Causes
When you create a migration job to DLI on the CDM console, you set Resource Queue to a DLI queue for general purpose. It should be a queue for SQL.
Solution
- On the DLI management console and click Queue Management in the navigation pane on the left. On the Queue Management page, check whether there are SQL queues.
- Choose Resources > Resource Pool. On the displayed page, locate the purchased elastic resource pool, and click Add Queue in the Operation column. Set Type to For SQL, set other parameters, and submit the creation request.
- Go back to the CDM console and create a data migration job. Set Resource Queue to the created DLI SQL queue.
- Submit the migration job and view the job execution logs.
Parent topic: SQL Job O&M
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
The system is busy. Please try again later.
For any further questions, feel free to contact us through the chatbot.
Chatbot