Help Center/ Cloud Container Engine/ FAQs/ Cluster/ Cluster Deletion/ What Can I Do If a Cluster Deletion Fails Because the VPC Sharing Is Canceled?
Updated on 2026-05-25 GMT+08:00

What Can I Do If a Cluster Deletion Fails Because the VPC Sharing Is Canceled?

Symptom

A cluster fails to be deleted, and the following information is displayed:

delete failed after 5 retry times: wait dependencies failed: dependency failed: vpc-eni-port|***, reason: delete failed: {"code":"vpc-eni-port|***","action":"Eni:DetachPort:Error","message":"dettach port *** to server *** failed: Expected HTTP response code [200 201 202 203 204] when accessing [POST https://ecs.***.huawei.com/v1/***/cloudservers/***/nics/delete], but got 400 instead\n{\"error\":{\"message\":\"Failed to view the network: {\\\"NeutronError\\\":{\\\"message\\\":\\\"Network ***SubnetID** could not be found.\\\",\\\"type\\\":\\\"NetworkNotFound\\\",\\\"detail\\\":\\\"\\\"}}\",\"code\":\"Ecs.0310\"}}"};CloudService=CCE,Service=S-CCE

Possible Cause

The cluster was created using a VPC and subnet shared by another account. After the sharing is canceled, the account cannot view the shared VPC and subnet. As a result, the cluster fails to be deleted.

For details about how to create a cluster using VPC sharing, see Creating a CCE Turbo Cluster Using VPC Sharing.

Solution

Ask the account that cancels the sharing to share the VPC and subnet again. For details about the subnet ID, see "Network *** could not be found" in the error message. If you are unsure which account canceled the sharing, submit a service ticket.

After the VPC and subnet are shared again, retry deleting the cluster.

For details about how to share the VPC and subnet again, see Sharing a Subnet with Other Accounts.