How Can I Troubleshoot Exceptions That Occur with an Add-on?
If there is an exception during add-on installation, upgrade, or configuration modification, the console will show an error code. By referring to the error code, you can identify the issue and explore the possible causes and solutions. This section provides information on common error codes, their possible causes, and corresponding solutions.
Resource Conflict
Symptom
An internal error occurs during the add-on installation. The error code is CCE.03500001.
Possible Cause
When an internal error occurs, the error message will provide details about the specific cause of the error. For example, if you see the message "ClusterRole \"gatekeeper-manager-role\" in namespace \"\" exists and cannot be imported into the current release," it means that the ClusterRole resource has been created in the cluster, but it is not being managed by the add-on.
Solution
Use kubectl to delete the conflicting resources that are not managed by the add-on and install the add-on again.
Installation Timed Out
Symptom
When an add-on installation or upgrade fails, the system will display a message indicating that the installation has timed out.
Release "*****" failed: failed pre-install: timed out waiting for the condition
Possible Cause
The add-on pod is not ready.
Solution
On the Overview page, view the Kubernetes events to determine the reason why the pod is not ready.
Cause |
Solution |
---|---|
The pod cannot be scheduled. |
Event: FailedScheduling Cause: The nodes in the cluster cannot accept the pod. The possible causes are as follows: (You can determine the specific cause based on the event details.)
Solution: Take the following steps and ensure that the add-on pod's scheduling requirements are met. Once done, install the add-on again.
|
The pod cannot be created. |
Rectify the creation failure by referring to How Can I Locate the Root Cause If a Workload Is Abnormal? |
Add-on Resources Not Exist
Symptom
When an add-on is updated or upgraded, a message is displayed indicating that update has failed and an error 404 is reported.
update release failed: update release failed {"error":{"message"."Get release failed: get v3 release by cluster failed, error: release: not found","code":"SVCSTG.CCECAM.4040204"}}, 404
Possible Cause
The related resources have been changed or deleted, so an exception occurred while getting the add-on related resources. As a result, the add-on cannot be updated or upgraded directly.
Solution
Uninstall the add-on and install the latest version of it.
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