Updated on 2026-09-29 GMT+08:00

Resource Statuses

Cloud Server Statuses

An ECS can be in one of the following statuses specified in ECS APIs:

  • status: specifies an ECS status, which is generated by OS-EXT-STS:vm_state and OS-EXT-STS:task_state.
  • OS-EXT-STS:vm_state: indicates that the ECS is in a stable state after an operation is performed. This is an extended attribute.
  • OS-EXT-STS:task_state: indicates an intermediate status in which the ECS is processing an operation performed on it. This is an extended attribute.
Table 1 Statuses

Status

Description

BUILD

The ECS has been created but is not running yet.

REBOOT

The ECS is being restarted.

HARD_REBOOT

The ECS is being forcibly restarted.

REBUILD

The ECS is being rebuilt.

MIGRATING

The ECS is undergoing live migration.

RESIZE

The ECS has received a specifications modification request and has started to perform the modification.

ACTIVE

The ECS is running properly.

SHUTOFF

The ECS has been properly stopped.

REVERT_RESIZE

The ECS is rolling back to its previous size.

VERIFY_RESIZE

The ECS is verifying the new size.

ERROR

The ECS is abnormal.

DELETED

The ECS has been deleted.

SHELVED

The ECS booting from an image is shelved.

SHELVED_OFFLOADED

The ECS booting from a volume is shelved.

UNKNOWN

The ECS status is unknown.

Table 2 OS-EXT-STS:vm_state statuses

Status

Description

building

The ECS has been created but is not running yet.

active

The ECS is running properly.

stopped

The ECS has been properly stopped.

resized

The ECS has been resized (specifications have been modified).

error

The ECS is abnormal.

deleted

The ECS has been deleted.

shelved

The ECS booting from an image is shelved.

shelved_offloaded

The ECS booting from a volume is shelved.

Table 3 OS-EXT-STS:task_state statuses

Status

Description

scheduling

The system is scheduling resources when the ECS is being created.

block_device_mapping

Disks are being prepared for the ECS that is being created.

networking

Networking resources are being prepared for the ECS that is being created.

spawning

The ECS is being created internally.

rebooting

The ECS is being restarted.

reboot_pending

The ECS is pending a restart.

reboot_started

The ECS is being restarted internally.

rebooting_hard

The ECS is being forcibly restarted.

reboot_pending_hard

The ECS is pending a force restart.

reboot_started_hard

The ECS is being forcibly restarted internally.

rebuilding

The ECS is being rebuilt.

rebuild_block_device_mapping

Disks are being prepared for the ECS that is being rebuilt.

rebuild_spawning

The ECS is being rebuilt internally.

migrating

The ECS is undergoing live migration.

resize_prep

The ECS is preparing for being resized.

resize_migrating

The ECS is undergoing migration during the resize phase.

resize_migrated

The ECS has finished migration during the resize phase.

resize_finish

The ECS is finishing the resize operation during the resize phase.

resize_reverting

The ECS is rolling back to its previous size during the resize phase.

powering-off

The ECS is being stopped.

powering-on

The ECS is being started.

deleting

The ECS is being deleted.

shelving

The ECS booting from an image is being shelved.

shelving_offloading

The ECS booting from a volume is being shelved.

shelving_image_pending_upload

A shelving image is pending upload.

shelving_image_uploading

A shelving image is being uploaded.

unshelving

The ECS is being unshelved.

Table 4 Mapping between statuses

vm_state

task_state

status

building

scheduling

block_device_mapping

networking

spawning

null

BUILD

active

rebooting

reboot_pending

reboot_started

REBOOT

rebooting_hard

reboot_pending_hard

reboot_started_hard

HARD_REBOOT

rebuilding

rebuild_block_device_mapping

rebuild_spawning

REBUILD

migrating

MIGRATING

powering-off

deleting

null

ACTIVE

stopped

resize_prep

resize_migrating

resize_migrated

resize_finish

RESIZE

rebuilding

rebuild_block_device_mapping

rebuild_spawning

REBUILD

powering-on

deleting

null

SHUTOFF

resized

resize_reverting

REVERT_RESIZE

null

VERIFY_RESIZE

error

rebuilding

rebuild_block_device_mapping

rebuild_spawning

REBUILD

deleting

null

ERROR

deleted

null

DELETED

shelved

shelving

shelving_image_pending_upload

shelving_image_uploading

unshelving

null

SHELVED

shelved_offloaded

shelving_offloading

unshelving

null

SHELVED_OFFLOADED

Cloud Disk Statuses

EVS Disk Status (API)

EVS Disk Status (Console)

Description

creating

Creating

The EVS disk is being created.

available

Available

The EVS disk has not been attached to any server, so you can attach it.

in-use

In-use

The EVS disk has been attached to a server and is in use.

error

Error

An error occurs when you try to create an EVS disk.

attaching

Attaching

The EVS disk is being attached.

detaching

Detaching

The EVS disk is being detached.

restoring-backup

Restoring

The EVS disk is being restored from a backup.

backing-up

Backing up

A backup is being created for the EVS disk.

error_restoring

Restoration failed

An error occurs when you try to restore the EVS disk from a backup.

uploading

Uploading

Data on the EVS disk is being uploaded to an image. This status occurs when you create an image from a server.

downloading

Downloading

Data is being downloaded from an image to the EVS disk. This status occurs when you create a server.

extending

Expanding

The capacity of the EVS disk is being expanded.

error_extending

Expansion failed

An error occurs when you try to expand the capacity of the EVS disk.

deleting

Deleting

The EVS disk is being deleted.

error_deleting

Deletion failed

An error occurs when you try to delete the EVS disk.

rollbacking

Rolling back

Data on the EVS disk is being restored from a snapshot.

NOTE:
  • When you roll back a snapshot, you can only restore the data to the original disk. Data restoration to a specific disk is not possible.
  • A snapshot can only be rolled back when the original disk is in the available or error_rollbacking state.

error_rollbacking

Rollback failed

An error occurs when a snapshot is being rolled back.

awaiting-transfer

Awaiting transfer

The EVS disk is awaiting for a transfer.

SFS Turbo File System Statuses

Status

Description

CREATING

The file system is being created.

ACTIVE

The SFS Turbo file system is active and can be mounted.

FAILED

The file system failed.

CREATE_FAILED

The file system failed to be created.

DELETED

The file system is deleted.

FROZEN

The file system is frozen.

Desktop Statuses

The following status fields are returned by the Workspace API for querying desktop details:

  • status: power supply status of a desktop
  • task_status: task status of a desktop, that is, the intermediate status of a desktop when the desktop is processing an operation
  • login_status: connection status of a desktop
You can view only the following two statuses on the console:
  • Running status: consists of task_status and status. If task_status is not empty, its status value is displayed. If task_status is empty, the status value of status is displayed.
  • Connection status: consists of login_status. Table 7 describes each status in detail and the status values displayed on the console.
    Table 5 status list

    status

    Description

    ACTIVE

    Running

    SHUTOFF

    Stopped

    HIBERNATED

    Hibernated

    ERROR

    Faulty

    STARTING

    Starting

    STOPPING

    Stopping

    RESTARTING

    Restarting

    HIBERNATING

    Hibernating

    AWAKENING

    Waking up

    Table 6 task_status list

    task_status

    Description

    CreatedSuccess

    Created

    creating

    Creating

    Deleting

    Deleting

    updating

    Rebuilding

    attaching

    Assigning a desktop to a user

    DesktopDetaching

    Unbinding a user

    desktopNetworkChanging

    Changing the network

    userPrivilegeGroupChanging

    Changing the user permission group

    migrating

    Cold migrating

    updatingSids

    Updating the SID

    rejoiningDomain

    Rejoining the domain

    restoring

    Restoring a desktop

    addingVolumes

    Adding a disk

    deletingVolumes

    Deleting a disk

    expandingVolumes

    Expanding disk capacity

    desktopToImage

    Creating an image

    acrossAzDesktopMigrating

    Migrating across AZs

    desktopResizing

    Changing specifications

    creatingWksSnapshot

    Creating a snapshot

    restoringWksSnapshot

    Restoring a snapshot

    Table 7 login_status list

    login_status

    Description

    Connection Status Displayed on the Console (New Version)

    Connection Status Displayed on the Console (Old Version)

    CONNECTED

    The user is connecting to a desktop.

    Connected

    In use

    DISCONNECTED

    The user has disconnected from a desktop after using it.

    Unconnected

    Disconnected

    REGISTERED

    The desktop is ready after being started.

    Ready

    OFFLINE

    The desktop is offline because it is stopped or hibernated.

    Offline

    UNREGISTER

    The desktop cannot be connected to temporarily due to abnormal registration status. If there is an ongoing task, wait until the task is completed and then check the status. If the connection cannot be established for a long time, you can remotely log in to check the issue or restart the desktop.

    Connection failed

    Connection failed