How Do I Rectify the Fault When the Cluster Status Is Unavailable?
If the cluster is Unavailable, perform the following operations to rectify the fault:
Troubleshooting Process
The issues here are described in order of how likely they are to occur.
Check these causes one by one until you find the cause of the fault.
- Check Item 1: Whether the Security Group Is Modified
- Check Item 2: Whether There Are Residual Listeners and Backend Server Groups on the Load Balancer
Check Item 1: Whether the Security Group Is Modified
- Log in to the management console, and choose Service List > Networking > Virtual Private Cloud. In the navigation pane on the left, choose Access Control > Security Groups to find the security group of the master node in the cluster.
The name of this security group is in the format of Cluster name-cce-control-ID.
- Click the security group. On the details page displayed, ensure that the security group rules of the master node are correct.
For details, see Configuring Cluster Security Group Rules.
Check Item 2: Whether There Are Residual Listeners and Backend Server Groups on the Load Balancer
Reproducing the Problem
A cluster exception occurs when a LoadBalancer Service is being created or deleted. After the fault is rectified, the Service is deleted successfully, but there are residual listeners and backend server group.
- Pre-create a CCE cluster. In the cluster, use the official Nginx image to create workloads, preset load balancers, Services, and ingresses.
- Ensure that the cluster is running properly and the Nginx workload is stable.
- Create and delete 10 LoadBalancer Services every 20 seconds.
- An injection exception occurs in the cluster. For example, the etcd pod is unavailable or the cluster is hibernated.
Possible Causes
There are residual listeners and backend server groups on the load balancer.
Solution
Manually clear residual listeners and backend server groups.
- Log in to the management console and choose Network > Elastic Load Balance from the service list.
- In the load balancer list, click the name of the target load balancer to go to the details page. On the Listeners tab page, locate the target listener and delete it.
- On the Backend Server Groups tab page, locate the target backend server group and delete it.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot