Updated on 2024-09-23 GMT+08:00

ALM-12104 Abnormal Knox Resources

Alarm Description

HA checks the Knox resources of Manager every 70 seconds. This alarm is generated when HA detects that the Knox resources are abnormal for three consecutive times.

This alarm is cleared when HA detects that the Knox resources are normal.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

12104

Major

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

Requests sent by upper-layer services by using Knox cannot be properly processed.

Possible Causes

The Knox process is abnormal.

Handling Procedure

Check whether the Knox process is normal.

  1. Log in to FusionInsight Manager. In the alarm list, locate the row that contains the alarm and view the name of the host for which the alarm is generated.
  2. Use PuTTY to log in to the host for which the alarm is generated as user root.
  3. Run the su - omm command to switch to user omm.
  4. Run the sh ${BIGDATA_HOME}/om-server/om/sbin/status-oms.sh command to check whether the status of the Knox resources managed by HA is normal. If the status is normal, the Knox resources are normal. Otherwise, the Knox resources are abnormal.

    • If yes, go to 7.
    • If no, go to 5.

  5. Run the vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/knox.log command to check whether the Knox resource log of HA contains the keyword ERROR. If yes, analyze the log to locate the resource exception cause and fix the exception.
  6. After 5 minutes, check whether this alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 7.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. In the Services area, select Controller and OmmServer, and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.