Help Center/ ModelArts/ Troubleshooting/ DevEnviron/ Custom Image Faults/ Unable to Access a Notebook Instance Created Using an Old Image
Updated on 2025-08-22 GMT+08:00

Unable to Access a Notebook Instance Created Using an Old Image

Symptom

If you created a notebook instance using an image registered before June 2023, the instance may run correctly and allow SSH connections, but its webpage might fail to load. You will see this error message:

Access to your notebook is denied due to lost token or incorrect token. Please log in again. Click here to return to the login page.
Figure 1 Error message example

Possible Causes

Notebook 1.0 was released before June 2023 and has been discontinued. You need to use the new version of notebook.

Solution

  1. Check whether the notebook instance is started using Notebook 1.0.
    1. Enable SSH remote development when creating a notebook instance. For more information, see Creating a Notebook Instance.
    2. After connecting to the notebook instance using SSH, check whether the notebook instance is started using Notebook 1.0.
      • Method 1: Run the df -h command.

        If the /modelarts directory is not found, the notebook instance is started using Notebook 1.0.

        Figure 2 /modelarts directory not found
      • Method 2: Run the ps -ef command to check processes.

        If the processes shown in the following figure are found, the notebook instance is started using Notebook 1.0.

        Figure 3 Checking processes
  2. Stop the notebook instance.
    1. Log in to the ModelArts console and choose Development Workspace > Notebook from the navigation pane.
    2. On the Notebook page, click Stop in the Operation column. In the displayed dialog box, click OK. For more information, see Starting, Stopping, or Deleting a Notebook Instance.
  3. Delete the historical image.
    1. Log in to the ModelArts console. In the navigation pane on the left, choose Image Management.
    2. On the Image Management page, click the target image name. In the Operation column, click Delete.
    3. In the displayed dialog box, enter DELETE and click OK.
  4. Register the image again.
    1. Log in to the ModelArts console. In the navigation pane on the left, choose Image Management.
    2. In the upper right corner, click Register.
    3. On the displayed page, set the parameters and click Register. For more information, see Creating a Custom Image for a Notebook Instance.
  5. Create a notebook instance using the newly registered image. For details, see Creating a Notebook Instance.