Help Center/ ModelArts/ Troubleshooting/ Inference Deployment/ Model Management/ Insufficient Disk Space Is Displayed When a Service Is Deployed After a Model Is Imported
Updated on 2025-06-06 GMT+08:00

Insufficient Disk Space Is Displayed When a Service Is Deployed After a Model Is Imported

Symptom

After a model is imported, message "No space left on device" is displayed during service deployment.

Possible Causes

ModelArts uses containers to deploy services. There are size limitations for containers to run. If the size of your model file, custom file, or system file exceeds the Docker size, a message will be displayed, indicating that the image space is insufficient.

Solution

The maximum Docker size for a container in a public resource pool is 50 GB, and that for a container in a dedicated resource pool is also 50 GB.

If the model is imported from OBS or a training job, the total size of the base image, model file, code, data file, and installed software packages is included.

If the model is imported from a custom image, the total size of the decompressed image and the downloaded image files is included.