Parsing Failed, and a Message Is Displayed Indicating That the OBS Connection Failed
Scenarios
When you create a to-the-cloud workload replay task and obtain workload files in the OBS bucket using an AK/SK, workload files failed to be parsed and a message is displayed indicating that the OBS connection failed.
Possible Causes
The possible causes are as follows:
- The AK, SK, bucket name, or endpoint is incorrect.
- You do not have the permission to read files in the OBS bucket.
Solution
Based on the previous analysis, a solution is provided as follows:
- Click the task name. The Basic Information page is displayed.
- In the Connection Information area, check whether the AK, SK, bucket name, and endpoint information is correct.
If a temporary AK/SK is used, you also need to check the permissions and validity period of the temporary AK/SK and security token.
- If the connection information is correct, go to 3.
- If the connection information is incorrect, click Pause in the Operation column of the task. After the task is paused, click Edit in the Operation column. On the Configure Source and Destination Databases page, enter information about the source database and task settings, and start the task.
- Check whether you have the permission to read files in the OBS bucket. For details about how to grant users the permission to read files in OBS buckets, see OBS Permissions Management.
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