Help Center/ Cloud Backup and Recovery/ Troubleshooting/ Failed to Install the Agent on Windows
Updated on 2024-07-24 GMT+08:00

Failed to Install the Agent on Windows

Scenario 1: User rdadmin Already Exists

Symptom

The Agent of application-consistent backup failed to be installed on a Windows server. Message "Agent working user rdadmin exist" is displayed.

Possible Causes

  • User rdadmin has been created on the Windows server before the Agent is installed.
  • If the Agent installation has been performed on the Windows server, user rdadmin will be created even if the installation fails.

Solution

  1. Log in to the Windows server, click the Windows icon in the lower left corner of the desktop, and choose Control Panel > User Accounts.
  2. Check whether user rdadmin exists. If the user exists, confirm that it is not created by other applications and then delete it.
  3. After the user is deleted, install the Agent again.

Scenario 2: Installation Failed Due to Registry Modification

Symptom

You have changed the default encoding format by modifying the registry.

Example: Create autorun in \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor and set its value to chcp 65001.

Solution

Change the value to chcp 65001 > nul.

  1. Press Win+R to open the Run dialog box and then enter regedit.
  2. Go to the \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor directory.
  3. Right-click and choose New > String Value (REG_SZ) from the shortcut menu. Name the string autorun.
  4. Double-click and change the value to chcp 65001 > nul.