Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-50224 Failures a Certain Task Type on BE Are Increasing
Updated on 2024-11-29 GMT+08:00

ALM-50224 Failures a Certain Task Type on BE Are Increasing

Alarm Description

The system checks whether the number of failed tasks of a certain type on BE is increasing every 30 seconds. This alarm is generated when the system detects that the value is not 1 (1 indicates that the number of failed tasks of a certain type does not increase, and 0 indicates that the failed tasks of a certain type are increasing).

This alarm is cleared when the system detects that the number of failed tasks of a certain type on BE does not increase.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

50224

Major

Error handling

Doris

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Additional Information

Detail

Specifies the alarm triggering condition.

Impact on the System

A task fails to be executed repeatedly in a certain scenario.

Possible Causes

A BE exception may occur. As a result, the number of failed tasks increases in a certain scenario.

Handling Procedure

Check whether the alarm threshold or alarm trigger count is properly configured.

  1. Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, and choose Doris > Exception > Check whether the number of failed tasks of a certain type increases (BE).
  2. Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
  3. Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
  4. Wait 2 minutes and check whether the alarm is automatically cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, select Doris for the target cluster, and click OK.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

You need to manually clear the alarm after the fault is rectified.

Related Information

None.