Updated on 2024-11-29 GMT+08:00

ALM-43607 Nginx Fault in GraphBase

Alarm Description

The system checks the Nginx service of GraphBase every 30 seconds. This alarm is generated when the Nginx service of GraphBase is abnormal during the HA health check.

This alarm is cleared when the Nginx service becomes normal during the HA health check.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

43607

Major

Error handling

GraphBase

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

  • The active and standby LoadBalancers of GraphBase may be switched over.
  • The GraphBase service may be unavailable.

Possible Causes

The Ngnix service is not running properly.

Handling Procedure

Check whether the node where GraphBase is deployed is normal.

  1. On FusionInsight Manager, select the alarm whose ID is 43607, and view the IP address of the instance in location information.
  2. Log in to the node for which the alarm is generated as user root.
  3. Go to the ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/ha/module/hacom/script/ directory and run the sh status_ha.sh script to check whether Nginx of the active Manager is normal. Specifically, check whether the following information is displayed in the line where ResName of the active management node is nginx:

    ngnix  Normal  Normal   Single_active
    • If yes, go to 5.
    • If no, go to 4.

  4. Contact the network administrator to check whether the network is faulty.

    • If yes, rectify the network fault and go to 5.
    • If no, go to 6.

  5. Wait for 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. In the Service area, select the following nodes of the desired cluster.

    • If the fault is caused by GraphBase, select GraphBase.
    • If the fault is caused by services on which GraphBase depends, select the faulty services and the GraphBase service. (The corresponding hosts are automatically selected once you select the services.)

  3. Click in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.