Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-25500 KrbServer Service Unavailable
Updated on 2024-11-29 GMT+08:00

ALM-25500 KrbServer Service Unavailable

Alarm Description

The system checks the KrbServer service status every 30 seconds. This alarm is generated when the system detects that the KrbServer service is abnormal.

This alarm is cleared when the system detects that the KrbServer service is normal.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

25500

Critical

Quality of service

FusionInsight Manager

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

The running status of the component that depends on the KrbServer becomes faulty. As a result, the Kerberos authentication of the cluster fails, and the component services are abnormal.

Possible Causes

  • The node where the KrbServer service locates is faulty.
  • The OLdap service is abnormal.

Handling Procedure

Check whether the node where the KrbServer service locates is faulty.

  1. On the FusionInsight Manager home page, choose Cluster > Name of the desired cluster > Services > KrbServer > Instance to go to the KrbServer instance page to obtain the host name of the node where the KrbServer service locates.
  2. On the Alarm page of the FusionInsight Manager system, check whether any alarm of NodeAgent Process Is Abnormal exists.

    • If yes, go to 3.
    • If no, go to 6.

  3. Check whether the host name in the alarm is consistent with the 1 host name.

    • If yes, go to 4.
    • If no, go to 6.

  4. Handle the alarm according to "ALM-12006 NodeAgent Process Is Abnormal".
  5. Check whether KrbServer Service Unavailable is cleared in the alarm list.

    • If yes, no further action is required.
    • If no, go to 6.

Check whether the OLdap service is normal.

  1. On the Alarm page of the FusionInsight Manager system, check whether any alarm of OLdap Resource Abnormal exists.

    • If yes, go to 7.
    • If no, go to 9.

  2. Handle the alarm according to "ALM-12004 OLdap Resource Abnormal".
  3. Check whether KrbServer Service Unavailable is cleared in the alarm list.

    • If yes, no further action is required.
    • If no, go to 9.

Collect fault information.

  1. On the FusionInsight Manager, choose O&M > Log > Download.
  2. Select KrbServer in the required cluster from the Service.
  3. Click the edit button in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M engineers and send the collected logs.

Alarm Clearance

After the fault is rectified, the system automatically clears this alarm.

Related Information

None.