ALM-12064 Host Random Port Range Conflicts with Cluster Used Port
Alarm Description
The system checks whether the random port range of the host conflicts with the range of ports used by the Cluster system every hour. The alarm is generated if they conflict. The alarm is automatically cleared when the random port range of the host is changed to the normal range.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
12064 |
Major |
Environment |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifiestheclusterorsystemforwhichthealarmisgenerated. |
ServiceName |
Specifies the name of the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- If ports such as okerberos and oldap are occupied, authentication fails and jobs may fail.
- If the controller and pms ports are occupied, the process is faulty, which may affect the elastic scaling performance.
- If the Tomcat port is occupied, the login and query functions of FusionInsight Manager are affected.
Possible Causes
The random port range configuration is modified.
Handling Procedure
Check the random port range of the system.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and view the IP address of the host for which the alarm is generated.
- Log in to the host where the alarm is generated as user root.
- Run the cat /proc/sys/net/ipv4/ip_local_port_range command to obtain the random port range of the host and check whether the minimum value is smaller than 32768.
- Run the vim /etc/sysctl.conf command to change the value of net.ipv4.ip_local_port_range to 32768 61000. If this parameter does not exist, add the following configuration: net.ipv4.ip_local_port_range = 32768 61000.
- Run the sysctl -p /etc/sysctl.conf command for the modification to take effect.
- One hour later, check whether the alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 7.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Select NodeAgent for Service and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected log information.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
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