How Do I Manually Detach the Temporary System Disk from My Target Server and Re-attach the Original System Disk?
The solution described here works for ECSs. It does not work for FlexusL instances because FlexusL does not allow you to detach or attach disks. If your target server is a FlexusL instance, submit a service ticket to get technical support.
Symptom
After you deleted a failed or suspended migration task from the SMS console, the target server was still using the temporary system disk whose name starts with SMS, and its original system disk could not be re-attached.
Possible Causes
If a migration task fails or is suspended, the system will not automatically detach the temporary system disk and re-attach the original system disk. If you want to restore this server to its original condition, you need to perform this step manually.
Solution
- Detach the temporary system disk.
- Log in to the ECS console.
- In the server list, locate this server and click its name.
- Click the Disks tab, locate disk SMS-Temp_Disk_Deleted-after-migration, and click Detach.
- Click Yes.
- Detach the original system disk.
The original system disk is attached as a data disk. You need to detach it and attach it as a system disk.
- Detach the original system disk from the target server by referring to step 1.
- Switch to the EVS console. In the disk list, locate the disk you detached and click the disk name.
Check whether the disk has changed from a Data disk to a Bootable disk. If it has, go to the next step.
- Detach the original system disk from the target server by referring to step 1.
- Re-attach the original system disk.
Re-attach the disk you detached in step 2 as a system disk to the target server. For details, see Calling APIs.
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