How Do I Resolve the "No such file or directory: 'rsync':'rsync" Error When I Start the Linux Agent?
Symptom
If this error message was displayed after you entered the AK/SK pair and start the Linux Agent, rsync was not installed on the source server. You need to install rsync and restart the Agent.
Possible Causes
Linux migration depends on rsync. If rsync is not installed on the source server, the Agent cannot be started.
Solutions
The operations for different OSs are as follows:
- Use PuTTY or another SSH client to log in to the source server as user root.
- Install rsync.
- Enter y and press Enter.
- Display rsync details.
If the following information is displayed, rsync has been installed:
- Start the Agent.
- Read the displayed information carefully, enter y, and press Enter.
Figure 2 Confirmation
- Enter the AK and SK of the account that you migrate to.
When the following information is displayed, the Agent has been started up and will automatically start reporting source server information to SMS.
- Use PuTTY or another SSH client to log in to the source server as user root.
- Install rsync.
- Enter y and press Enter.
- Display rsync details.
If the following information is displayed, rsync has been installed:
- Start the Agent.
- Read the displayed information carefully, enter y, and press Enter.
Figure 3 Confirmation
- Enter the AK and SK of the account that you migrate to.
When the following information is displayed, the Agent has been started up and will automatically start reporting source server information to SMS.
- Use PuTTY or another SSH client to log in to the source server as user root.
- Install rsync.
- Display rsync details.
If the following information is displayed, rsync has been installed:
- Start the Agent.
- Read the displayed information carefully, enter y, and press Enter.
- Enter the AK and SK of the account that you migrate to.
When the following information is displayed, the Agent has been started up and will automatically start reporting source server information to SMS.
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