Help Center> ModelArts> FAQs> Notebook (New Version)> Data Upload or Download> What Can I Do If a File Fails to Be Uploaded to a Notebook Instance?
Updated on 2024-06-15 GMT+08:00

What Can I Do If a File Fails to Be Uploaded to a Notebook Instance?

Symptom

  • The file upload process is fast but unsuccessful.
  • When a file is uploaded to a notebook instance, the uploading is consistently in progress on the GUI. When a file is uploaded through MoXing, an error occurred. When an OBS file is uploaded, no bucket is displayed, and the message "Obtaining data" is displayed.

  • When you click to upload files on the JupyterLab page, "Failed to obtain data" is displayed.
    Figure 1 OBS file upload

    When you check the notebook log (usually notebook-<date>.log in /home/ma-user/log/), the error message List objects failed, obs_client resp: {'status' : 403, 'reason' : 'Forbidden' , 'errorCode' : 'AccessDenied' is displayed.

Possible Cause

The first symptom is because that the size of a file is limited when it is uploaded through the Huawei intranet.

The possible causes of other symptoms are as follows:

  • OBS access is not authorized.
  • You do not have the permission to access the OBS bucket or file.
  • The OBS bucket has been deleted.

Solution

  • Check agency authorization.

    Go to the Global Configuration page and check whether you have the OBS access permission. If you do not, see Configuring Access Authorization (Global Configuration).

  • Check whether you have the permission to access the OBS bucket.

    Go to the OBS console, access the target bucket, and check if there is an error showing that you do not have the access permission.

  • Go to the OBS console and check whether the OBS bucket exists.

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