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Por que as permissões concedidas a um usuário não entram em vigor?

Atualizado em 2024-08-30 GMT+08:00

Sintoma

As permissões que você concede a um usuário do IAM não entram em vigor.

Solução de problemas

  1. Causa: permissões incorretas foram concedidas ao grupo de usuários ao qual o usuário pertence.

    Solução: peça ao administrador para modificar as permissões concedidas ao grupo de usuários ao qual o usuário do IAM pertence. Para obter detalhes, consulte Modificação de permissões de grupos de usuários. Para obter detalhes sobre permissões, consulte Permissões definidas pelo sistema.

  2. Causa: as ações são negadas pelas permissões concedidas ao usuário.

    Visualize as permissões definidas pelo sistema concedidas ao usuário do IAM e verifique se há uma declaração de política que nega a ação. Para obter detalhes, consulte Sintaxe da política. Se as permissões definidas pelo sistema não puderem atender aos seus requisitos, crie uma política personalizada para permitir a ação. Para obter detalhes, consulte Criação de uma política personalizada.

  3. Causa: o usuário do IAM não foi adicionado ao grupo de usuários com permissões atribuídas.

    Solução: adicione o usuário ao grupo de usuários de destino como administrador. Para obter detalhes, consulte Adição de usuários a um grupo de usuários.

  4. Causa: para um serviço regional, o grupo de usuários não é atribuído com permissões em regiões específicas.

    Atribua permissões ao grupo de usuários em regiões específicas. Se você tiver atribuído ao usuário apenas permissões para um projeto específico de região padrão, o usuário não terá permissões para os subprojetos. Nesse caso, atribua permissões para o subprojeto necessário. Para obter detalhes, consulte Atribuição de permissões a um grupo de usuários.

  5. Causa: o usuário do IAM não mudou para a região em que foi autorizado a usar os recursos de nuvem.

    Lembre o usuário de mudar para a região onde o usuário está autorizado a usar os recursos de nuvem. Para obter detalhes, consulte Mudança de regiões.

  6. Causa: se o administrador tiver concedido permissões do OBS ao usuário, as permissões entrarão em vigor de 15 a 30 minutos após a autorização.

    Verifique as permissões após 15 a 30 minutos e tente novamente.

  7. Causa: o cache do navegador não foi limpo por um longo tempo.

    Limpe o cache do navegador e tente novamente.

  8. Causa: o serviço (como OBS) fornece controle de permissões separado.

    Conceda permissões ao usuário consultando a documentação do serviço. Por exemplo, consulte Introdução ao controle de permissões do OBS.

  9. Causa: se você concedeu permissões a um usuário no IAM e no Enterprise Management, as permissões para projetos empresariais podem não entrar em vigor. A autenticação do IAM tem precedência sobre a autenticação do Enterprise Management. Se um usuário do IAM tiver a permissão ECS ReadOnlyAccess para todos os recursos e o projeto empresarial A, ele poderá visualizar todos os recursos do ECS.

    Modifique as permissões do usuário no console do IAM.

Pergunta frequente relacionada

Sintoma: você concedeu a um usuário do IAM apenas as permissões necessárias, mas o usuário tem mais permissões.

Possíveis causas:

  1. As permissões necessárias concedidas ao usuário do IAM têm permissões de dependência, que são atribuídas automaticamente para que as permissões necessárias entrem em vigor para o usuário.
  2. Você concedeu outras permissões ao usuário do IAM no Gerenciamento de projetos empresariais. Se você gerencia projetos e usuários usando o IAM, cancele as permissões configuradas lá. Para obter detalhes, consulte Exclusão de projetos empresariais gerenciados por um usuário.

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