O que devo fazer se a atualização do HSS falhar?
Sobre a atualização
- Os servidores são exibidos tanto no console anterior quanto no novo do HSS, independentemente de seus agentes terem sido atualizados. Os status do servidor são exibidos corretamente no console que você está usando.
- A atualização do agente é gratuita.
- Antes de atualização, certifique-se de que Agent Status esteja Online.
- A atualização não afeta as cargas de trabalho em seus servidores de nuvem.
- Após a atualização, a cobrança é interrompida no console anterior e iniciada no novo console.
- Após a atualização, seus servidores estarão protegidos por HSS (novo).
Como o agente é atualizado
Depois de iniciar a atualização do agente no console do HSS, o sistema desinstala automaticamente o agente 1.0 e, em seguida, instala o agente 2.0.
- No console anterior, os status do agente durante a atualização são os seguintes:
- Upgraded: o agente foi atualizado. Você pode ir para o console do HSS (novo) para verificar o status da proteção.
- Upgrading: o agente está sendo atualizado.
- Upgrade failed: o agente falhou ao ser atualizado.
- No novo console, os status do agente durante a atualização são os seguintes:
- Uninstalled: o servidor de destino não instalou um agente no novo console.
- Online: o agente está sendo executado corretamente.
- Offline: a comunicação do agente está anormal.
Possíveis causas
Após a conclusão da atualização automática, leva de 5 a 10 minutos para que o status do agente seja atualizado.
As possíveis causas de status anormais do agente são as seguintes:
- Falha na resolução de DNS. O agente pode ser atualizado somente por meio de resolução de DNS da intranet. Verifique se o endereço do servidor DNS privado está correto.
- O acesso à porta 10180 é restrito. A atualização do agente requer acesso à porta 10180.
- A memória disponível da VM é insuficiente. A atualização do agente ocupa determinada memória. Se a memória disponível for inferior a 300 MB, a atualização será afectada.
- Falha ao obter os metadados. Para atualizar o agente, é necessário obter o ID, o nome e a região do servidor.
Localizar e corrigir o problema
- Falha na resolução de DNS
- Procedimento de solução de problemas
- Use uma ferramenta de gerenciamento remoto, como SecureFX ou WinSCP, para fazer logon no servidor.
- Execute o seguinte comando para verificar o endereço de DNS privado do servidor:
- Anote o endereço de DNS e a região do servidor e verifique se eles estão corretos. Para obter detalhes, consulte Endereço do servidor DNS privado.
- Se a sua região e o endereço do servidor DNS corresponderem, o problema não foi causado pela resolução do DNS. Neste caso, verifique se há outras causas.
Se a sua região e o endereço do servidor DNS não corresponderem, o problema foi causado por uma falha de resolução de DNS.
- Solução
Verifique se seus serviços serão afetados se o endereço do servidor DNS privado configurado no servidor for alterado.
- Se os seus serviços não forem afetados pela alteração de endereço, corrija o endereço do servidor DNS privado e tente fazer a atualização novamente. Para obter detalhes, consulte Alteração do endereço do servidor DNS privado.
- Se os seus serviços forem afetados pela alteração de endereço, crie o mapeamento entre o nome do servidor e o endereço IP atual e tente fazer a atualização novamente. Execute as seguintes etapas:
- Faça logon no seu servidor de nuvem.
- Execute o seguinte comando para alternar para o usuário root:
sudo su -
- Execute o seguinte comando para editar o arquivo de configuração de hosts:
vi /etc/hosts
- Pressione i para entrar no modo de edição.
- Adicione declarações no seguinte formato:
[Exemplo]
192.168.0.1 hostname01
192.168.0.2 hostname02
- Pressione Esc para sair do modo de edição.
- Execute o seguinte comando para salvar a configuração e sair:
- Procedimento de solução de problemas
- Acesso restrito à porta 10180
Certifique-se de que o servidor onde o agente será instalado ou atualizado possa se comunicar com o segmento de rede. O grupo de segurança do seu servidor deve permitir acesso de saída à porta 10180 no segmento de rede 100.125.X.X/16.
- Procedimento de solução de problemas
- No canto superior esquerdo da página, selecione uma região, clique em e escolha Compute > Elastic Cloud Server.
- Clique no nome do servidor. Na página de detalhes do servidor que é exibida, clique na guia Security Groups.
- Clique na guia Outbound Rules e verifique se a porta 10180 é especificada na política de negação.
- Se não for especificada, o problema não foi causado pela restrição de acesso à porta.
- Se for especificada, o problema foi causado pela restrição de acesso à porta.
- Solução
Permite o acesso à porta. Para obter detalhes, consulte a etapa 8 em Configuração de regras de grupo de segurança.
- Procedimento de solução de problemas
- Memória de VM insuficiente
- Procedimento de solução de problemas
- Use uma ferramenta de gerenciamento remoto, como SecureFX ou WinSCP, para fazer logon no servidor.
- Execute o seguinte comando para verificar o uso de memória do servidor:
- Verifique o valor de free na saída do comando, como mostrado na Figura 1.
- Solução
- Feche as aplicações com alto uso de memória.
- Expanda a memória e tente novamente a instalação. Para obter detalhes sobre como expandir a capacidade de memória, consulte Operações gerais para modificar especificações.
- Procedimento de solução de problemas
- Falha ao obter metadados
- Procedimento de solução de problemas
Para obter detalhes sobre como verificar se os metadados podem ser obtidos, consulte Obtenção de metadados.
- Solução
Defina a rota para 169.254.169.254. Para obter detalhes, consulte Por que meu ECS do Linux não consegue obter metadados?
- Procedimento de solução de problemas