| A conexão expirou. Erro de rede. | - Linux
- Verifique se o servidor pode acessar a rede.
- Se o acesso à rede estiver normal, vá para 2.
- Se o acesso à rede estiver anormal, verifique a configuração da rede para garantir que o servidor possa acessar a rede.
- Verifique se a porta 22 está habilitada na direção de entrada do grupo de segurança ao qual o servidor pertence.
O HSS fará login no servidor usando SSH para instalar o agente. Se a porta 22 não estiver habilitada, o HSS não poderá instalar o agente. Para obter detalhes sobre como configurar um grupo de segurança, consulte Configuração de regras de grupo de segurança. - Windows
- Verifique se o servidor pode acessar a rede.
- Se o acesso à rede estiver normal, vá para 2.
- Se o acesso à rede estiver anormal, verifique a configuração da rede para garantir que o servidor possa acessar a rede.
- Verifique se a porta 5985 está habilitada na direção de entrada do grupo de segurança ao qual o servidor pertence.
A porta 5985 precisa estar habilitada se os agentes forem instalados em lote em servidores usando scripts. O servidor onde o script é executado precisa acessar a porta 5985 em outros servidores. Você precisa modificar as regras de entrada dos grupos de segurança nesses servidores para permitir o acesso a partir do endereço IP do servidor que executa o script. O HSS usa o servidor que executa o script como executor e faz login em outros servidores por meio da porta 5985 para instalar o agente. Para obter detalhes sobre como configurar um grupo de segurança, consulte Configuração de regras de grupo de segurança. |
| Falha na autenticação devido à senha incorreta. | Senha incorreta. Verifique a senha inserida. |
| O espaço de memória é insuficiente. | Ao instalar o agente, certifique-se de que pelo menos 50 MB de memória estejam disponíveis. Verifique e libere memória. |
| Metadados inválidos. | Falha ao obter os metadados. Para obter detalhes, consulte Por que meu ECS Linux não consegue obter metadados? |
| Falha ao instalar expect. | Verifique se a rede está instável. Após a recuperação da rede, instale o agente novamente. Se a rede estiver normal, mas a instalação ainda falhar, escolha Service Tickets > Create Service Ticket no canto superior direito do console de gerenciamento da Huawei Cloud para entrar em contato com o suporte técnico. |
| Falha ao conectar-se à VPC. | O HSS não tem a permissão VPCOperatePolicy. O HSS não pode se comunicar entre VPCs. Recomendamos que você execute as seguintes operações para conceder a permissão: - Faça logon no console de HSS.
- Clique em
no canto superior esquerdo e selecione uma região e um projeto. - No painel de navegação, escolha .
- Clique em Assign no canto superior esquerdo da lista de permissões para conceder a permissão VPCOperatePolicy ao HSS.
Para obter detalhes sobre a permissão VPCOperatePolicy, consulte Autorização. |
| Status anormal da chave DEW. | Verifique e restaure seu par de chaves DEW para o estado normal. |
| Falha ao conectar-se à VPCEP. | O HSS não tem a permissão VPCEPOperatePolicy. O HSS não pode criar um ponto de extremidade da VPC. O ponto de extremidade da VPC é usado para comunicação entre o agente e o servidor HSS. Recomendamos que você execute as seguintes operações para conceder a permissão: - Faça logon no console de HSS.
- Clique em
no canto superior esquerdo e selecione a região e o projeto desejados. - No painel de navegação, escolha .
- Clique em Assign no canto superior esquerdo da lista de permissões para conceder a permissão VPCEPOperatePolicy ao HSS.
Para obter detalhes sobre a permissão VPCEPOperatePolicy, consulte Autorização. |
| Falha ao fazer login usando a chave. | Chave incorreta. Verifique a chave que você inseriu. |
| Permissões insuficientes para executar o comando de instalação. | Possível causa: o script não pode ser executado no diretório /tmp ou o bash não tem permissão de execução. Sugestão: - Recomendamos verificar se os diretórios ou arquivos anteriores têm as permissões correspondentes.
- Se as permissões tiverem sido concedidas, mas a instalação ainda falhar, escolha Service Tickets > Create Service Ticket no canto superior direito do console de gerenciamento da Huawei Cloud para entrar em contato com o suporte técnico.
|
| Falha ao baixar o arquivo de instalação. | Esse erro ocorre apenas em servidores Linux. Recomendamos executar as seguintes operações para verificar as configurações do grupo de segurança e do DNS. - Verificação do grupo de segurança
Faça login no servidor e execute o seguinte comando para verificar se a porta 10180 do bloco CIDR 100.125.0.0/16 é permitida na direção de saída do grupo de segurança do servidor: curl -kv https://hss-agent.region code.myhuaweicloud.com:10180 Cada região tem um código de região exclusivo. Para obter detalhes sobre o código da região. Use CN North-Beijing1 como exemplo. O comando completo é o seguinte: curl -kv https://hss-agent.cn-north-1.myhuaweicloud.com:10180 - Se o comando ping for executado com sucesso, a porta 10180 do bloco CIDR 100.125.0.0/16 será habilitada.
- Se a página for suspensa após a execução do comando ping, a porta 10180 no segmento de rede 100.125.0.0/16 não será permitida. Para obter detalhes sobre como permitir a porta, consulte Adição de uma regra de grupo de segurança.
- Verificação das configurações de DNS
Faça login no servidor e execute o seguinte comando para verificar se o DNS do servidor pode resolver o nome de domínio para o download do agente: ping -c 1 hss-agent.RegionCode.myhuaweicloud.com Cada região tem um código de região exclusivo. Para obter detalhes sobre o código da região. Use CN North-Beijing1 como exemplo. O comando completo é o seguinte: ping -c 1 hss-agent.cn-north-1.myhuaweicloud.com - Se o endereço IP resolvido for exibido, a resolução de DNS está normal.
- Se name or service not known for exibido ou nenhum endereço IP for resolvido, a resolução DNS falhará. Para obter detalhes, consulte Modificação do DNS.
|
| Espaço insuficiente no disco. | Verifique os seguintes diretórios para garantir que a capacidade do disco seja suficiente: - Linux
- /usr/local: caminho de instalação padrão do agente. Certifique-se de que o espaço em disco disponível seja maior que 300 MB.
- /temp: caminho para baixar o pacote de instalação do agente. Certifique-se de que o espaço em disco disponível seja maior que 100 MB.
- Windows
- C:\Users\xxx\Downloads: caminho para baixar o pacote de instalação do agente. Certifique-se de que o espaço em disco disponível seja maior que 100 MB.
- C:\Program Files\HostGuard: caminho de instalação padrão do agente. Certifique-se de que o espaço em disco disponível seja maior que 300 MB.
|
| Não há chaves privadas gerenciadas pelo DEW. | Verifique e certifique-se de que seu par de chaves seja gerenciado pelo DEW. Se o par de chaves já for gerenciado pelo DEW, mas o HSS ainda exibir uma mensagem indicando que a chave privada gerenciada não foi encontrada ao instalar o agente, a possível causa é que sua conta atual seja uma conta de membro do IAM ou uma conta delegada e não tenha permissões para o KPS no DEW. Você pode acessar o console do IAM e usar um dos seguintes métodos para conceder permissões: - Método 1: conceda a permissão DEW KeypairFullAccess (permissões completas para KPS) à conta de instalação do agente.
- Método 2: de você não quiser que a conta de instalação do agente tenha permissão para excluir pares de chaves, você pode criar a seguinte política personalizada e conceder a política à conta. Para obter detalhes, consulte Criação de uma política personalizada.
Permitir que os usuários consultem e exportem pares de chaves {
"Version": "1.1",
"Statement": [
{
"Action": [
"kps:domainKeypairs:exportpk",
"kps:domainKeypairs:list",
"kps:domainKeypairs:get"
],
"Effect": "Allow"
}
]
} |
| Erro de instalação. | Realize as operações a seguir: - Faça logon no console de HSS.
- Clique em
no canto superior esquerdo e selecione a região e o projeto desejados. - No painel de navegação, escolha .
- Verifique se as permissões VPCEPOperatePolicy e VPCOperatePolicy estão na lista de permissões.
|
| A rede da VPC não pode ser conectada devido a conflitos de rota da NIC. | Um conflito de rota ocorre entre a NIC do seu servidor e a NIC elástica conectada ao servidor onde o agente está sendo instalado. A rede da VPC não pode ser conectada. Recomendamos que você instale o agente usando comandos. Para obter detalhes, consulte Uso de comandos ou scripts para instalar o agente em servidores da Huawei Cloud (instalação com conta atual). |
| Não há servidor com um agente online na versão mais recente na VPC atual. | - Verifique se há pelo menos um servidor com um agente online na VPC onde o servidor de destino está localizado.
- Verifique se a versão do agente é 3.2.13 ou posterior.
|
| Falha na instalação | Instale o agente novamente. Se a instalação falhar novamente, clique em Service Tickets > Create Service Ticket no canto superior direito do console de gerenciamento para entrar em contato com o suporte técnico. |