What Should I Do If a Yearly/Monthly EVS Disk Cannot Be Automatically Created?
Symptom
When creating a yearly/monthly EVS disk, payment permissions cannot be added to cce_cluster_agency.
Possible Causes
cce_cluster_agency is the system agency of CCE. It contains the cloud service resource operation permissions required by CCE components, but does not include the payment permissions. For details, see System Entrustment Description. When creating yearly/monthly EVS disks, cce_cluster_agency must have the payment permissions, so you must manually add the bss:order:pay permission to cce_cluster_agency.
Solution
You can create a custom policy, add the bss:order:pay permission to it, and grant the policy to cce_cluster_agency.
- Create a custom policy.
- Log in to the IAM console. In the navigation pane, choose Permissions > Policies/Roles. Then click Create Custom Policy.
- Configure parameters for the policy.
- Policy Name: Set it to CCE Subscribe Operator.
- Policy View: Select JSON.
- Policy Content: Configure it as follows:
{ "Version": "1.1", "Statement": [ { "Effect": "Allow", "Action": [ "bss:order:pay" ] } ] }
- Click OK.
- Grant the custom policy to cce_cluster_agency.
- Log in to the IAM console. In the navigation pane, choose Agencies.
- Locate the agency named cce_cluster_agency and click Authorize.
- Search for the CCE Subscribe Operator custom policy, select it, and click Next.
Select an authorization scope as needed.
By default, All resources is selected.
- Click OK.
- Go back to the CCE console, create a yearly/monthly EVS disk again, and verify that this problem has been resolved.
Storage FAQs
- How Do I Expand the Storage Capacity of a Container?
- What Are the Differences Among CCE Storage Classes in Terms of Persistent Storage and Multi-node Mounting?
- Can I Create a CCE Node Without Adding a Data Disk to the Node?
- Can EVS Volumes in a CCE Cluster Be Restored After They Are Deleted or Expired?
- What Should I Do If the Host Cannot Be Found When Files Need to Be Uploaded to OBS During the Access to the CCE Service from a Public Network?
- How Can I Achieve Compatibility Between ExtendPathMode and Kubernetes client-go?
- What Can I Do If a Storage Volume Fails to Be Created?
- Can CCE PVCs Detect Underlying Storage Faults?
- An Error Is Reported When the Owner Group and Permissions of the Mount Point of the SFS 3.0 File System in the OS Are Modified
- Why Cannot I Delete a PV or PVC Using the kubectl delete Command?
- What Should I Do If a Yearly/Monthly EVS Disk Cannot Be Automatically Created?
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbotmore