What Should I Do If a Release Creation or Upgrade Fails and "rendered manifests contain a resource that already exists" Is Displayed?
Symptom
When a release cannot be created or upgraded, the error message "Create release by helm failed:rendered manifests contain a resource that already exists" is displayed. Unable to continue with install: ..., label validation error:missing key \"app.kubernetes.io/managed-by\":must be set to\"Helm\" ... Failed to create the release.
Possible Causes
If the preceding error information is displayed, the release is not created using Helm v3. If a release with the same name exists in the environment and does not have the home tag app.kubernetes.io/managed-by: Helm of Helm v3, a conflict message is displayed.
Solution
Delete the release and create it again using Helm.
- Check the error message and locate the release that causes the conflict. Pay attention to the information following Unable to continue with install:. For example, the following error message indicates that a conflict occurs in the test-nginx Deployment in the default namespace.
- Go to the cluster console or run the following kubectl command to delete the test-nginx Deployment. The preceding information is only an example. Perform operations according to the actual error information.
kubectl delete deploy test-nginx -n default
- After the conflict is resolved, reinstall the chart.
Chart and Add-on FAQs
- What Should I Do If the nginx-ingress Add-on Fails to Be Installed on a Cluster and Remains in the Creating State?
- What Should I Do If Residual Process Resources Exist Due to an Earlier npd Add-on Version?
- What Should I Do If a Chart Release Cannot Be Deleted Because the Chart Format Is Incorrect?
- Does CCE Support nginx-ingress?
- What Should I Do If Installation of an Add-on Fails and "The release name is already exist" Is Displayed?
- What Should I Do If a Release Creation or Upgrade Fails and "rendered manifests contain a resource that already exists" Is Displayed?
- What Can I Do If the kube-prometheus-stack Add-on Instance Fails to Be Scheduled?
- What Can I Do If a Chart Fails to Be Uploaded?
- How Do I Configure the Add-on Resource Quotas Based on Cluster Scale?
- How Can I Clean Up Residual Resources After the NGINX Ingress Controller Add-on in the Unknown State Is Deleted?
- Why TLS v1.0 and v1.1 Cannot Be Used After the NGINX Ingress Controller Add-on Is Upgraded?
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