Help Center/ MapReduce Service/ User Guide/ MRS Cluster O&M/ MRS Cluster Alarm Handling Reference/ ALM-45452 ClickHouse's Local Disk Space Is Below the Cold-Hot Separation Threshold
Updated on 2024-11-13 GMT+08:00

ALM-45452 ClickHouse's Local Disk Space Is Below the Cold-Hot Separation Threshold

This section is available for MRS 3.3.1 or later version only.

Alarm Description

When cold-hot separation is enabled, the system checks the remaining space of the local disk specified in the cold-hot separation policy every 5 minutes. This alarm is generated if the remaining space is lower than the move_factor threshold.

This alarm is automatically cleared when the remaining space of the local disk is greater than the move_factor threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

45452

Major

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

Some hot data on the local disk is moved to OBS, affecting the read and write performance of the system.

Possible Causes

The local disk capacity configured for cold-hot separation on the ClickHouseServer node is too small.

Handling Procedure

  1. Log in to FusionInsight Manager, choose O&M > Alarm > Alarms, and view the role name and the IP address of the hostname in Location.
  2. Expand the disk capacity of the node for which the alarm is generated.
  3. Check whether the alarm is cleared after disk expansion.

    • If yes, no further action is required.
    • If no, go to 4.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select ClickHouse for the target cluster.
  3. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the abnormal host, and click OK.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.