Failed to Start a Service
Symptom
After a service is started, the system displays a message, indicating a container startup failure.
Possible Causes
Possible causes are as follows:
Faulty AI Application
If the image used for creating an AI application is faulty, recreate the image by following the instructions provided in Creating a Custom Image and Using It to Create an AI Application. Ensure the image can be started properly and the expected data can be returned through curl on the local host.
Incorrect Port in the Image
The port enabled in the image is not 8080, or the port enabled in the image is different from the port configured during AI application creation. As a result, the register-agent cannot communicate with the AI application during service deployment. After a certain period of time (20 minutes at most), it is considered that starting the AI application failed.
Incorrect Health Check Configuration
If health check is enabled in the image, perform the following operations to locate the fault:
- Check whether the health check port runs properly.
If health check is enabled in a custom image, check whether the health check API is functional during image test. For details about how to test an image locally, see Building a Custom Image and Using It to Create an AI Application.
Pulling an Image Failed
If the service fails to be started and a message is displayed indicating that the image fails to be pulled, see What Do I Do If an Image Fails to Be Pulled When a Service Is Deployed, Started, Upgraded, or Modified?
Scheduling Failed Due To Insufficient Resources
The service fails to be started, and a message is displayed indicating that resources are insufficient and service scheduling fails. For details, see What Do I Do If Resources Are Insufficient When a Service Is Deployed, Started, Upgraded, or Modified?.
Insufficient Memory
The service fails to be started, and a message is displayed indicating that the memory is insufficient. For details, see What Can I Do if the Memory Is Insufficient?.
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