ALM-45741 Guardian Failed to Call the ECS securitykey API
This section applies only to MRS 3.3.0 or later.
Alarm Description
Guardian caches the temporary AK/SK of the ECS agency. When the cache does not exist or is about to expire, Guardian calls the securitykey API of ECS to update the AK/SK. This alarm is generated when calling to the API fails.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45741 |
Major |
Quality of service |
Guardian |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The task may fail to obtain the temporary AK/SK for accessing OBS. As a result, OBS cannot be accessed.
Possible Causes
- No ECS agency is bound to the cluster.
- An underlying interface of ECS is abnormal.
Handling Procedure
Check whether an agency is bound to the cluster.
- Log in to the MRS management console.
- In the navigation pane on the left, choose Clusters > Active Clusters. On the page that is displayed, click the cluster name to go to its overview page. Then, check whether the cluster is bound to an agency in the O&M management area.
- Click Manage Agency. On the page that is displayed, rebind the cluster to an agency. Then check whether the alarm is cleared a few minutes later.
- If yes, no further action is required.
- If no, go to 4.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Guardian for the destination cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot