Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-45428 ClickHouse Disk I/O Exception
Updated on 2024-11-29 GMT+08:00

ALM-45428 ClickHouse Disk I/O Exception

Alarm Description

This alarm is generated when the alarm module detects EIO or EROFS errors during ClickHouse read and write every 60 seconds.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

45428

Major (default)

Quality of service

ClickHouse

No

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

  • ClickHouse fails to read and write data. The INSERT, SELECT, and CREATE operations on the local tables may be abnormal. Distributed tables are not affected.
  • Services are affected, and I/Os fail.

Possible Causes

The disk is aged or has bad sectors.

Handling Procedure

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms > ALM-45428 ClickHouse Disk I/O Exception. Check the role name and the IP address of the host where the alarm is generated in Location.
  2. Use PuTTY to log in to the node for which the fault is generated as user root.
  3. Run the df -h command to check the mount directory and find the disk mounted to the faulty directory.
  4. Run the smartctl -a /dev/sdFaulty disk command to check the disk. In the command, Faulty disk indicates the disk obtained in 3.

    • If SMART Health Status: OK is displayed, as shown in the following figure, the disk is healthy. In this case, go to 6.

    • If the number following Elements in grown defect list is not 0, as shown in the following figure, the disk may have bad sectors. If SMART Health Status: FAILURE is displayed, the disk is in the sub-health state.

  5. After the fault is rectified, manually clear the alarm on FusionInsight Manager and check whether the alarm is generated again during the periodic check.

    • If yes, go to 6.
    • If no, no further action is required.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select ClickHouse for the target cluster.
  3. Expand the Hosts drop-down list and select the target hosts.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M engineers and provide the collected logs.

Alarm Clearance

If the alarm has no impact, manually clear the alarm.

Related Information

None.