Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-45280 RangerAdmin GC Duration Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-45280 RangerAdmin GC Duration Exceeds the Threshold

Alarm Description

The system checks the GC duration of the RangerAdmin process every 60 seconds. This alarm is generated when the GC duration of the RangerAdmin process exceeds the threshold for five consecutive times. This alarm is cleared when the GC duration is less than the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

45280

Critical (default threshold: 20000ms)

Major (default threshold: 12000ms)

Quality of service

Ranger

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Additional Information

Trigger Condition

Specifies the alarm triggering condition.

Impact on the System

The RangerAdmin responds slowly to requests for creating, modifying, and deleting policies.

Possible Causes

The heap memory of the RangerAdmin instance is overused or the heap memory is inappropriately allocated. As a result, GCs occur frequently.

Handling Procedure

Check the GC duration.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms > ALM-45280 RangerAdmin GC Duration Exceeds the Threshold. Check the location information of the alarm and view the host name of the instance for which the alarm is generated.
  2. On FusionInsight Manager, choose Cluster > Services > Ranger > Instance. Select the role corresponding to the host name of the instance for which the alarm is generated and click the drop-down list in the upper right corner of the chart area. Choose Customize > GC > RangerAdmin GC Duration. Click OK.
  3. Check whether the GC duration of the RangerAdmin process collected every minute exceeds the threshold (12 seconds by default).

    • If yes, go to 4.
    • If no, go to 6.

  4. On FusionInsight Manager, choose Cluster > Services > Ranger > Instance > RangerAdmin > Instance Configuration. Click All Configurations, and choose RangerAdmin > System. Increase the value of -Xmx in the GC_OPTS parameter based on the site requirements and save the configuration.

    If this alarm is generated, the heap memory configured for RangerAdmin cannot meet the heap memory required by the RangerAdmin process. You are advised to check the heap memory usage of RangerAdmin and change the value of -Xmx in GC_OPTS to the twice of the heap memory used by RangerAdmin. The value can be changed based on the actual service scenario. For details, see 2.

  5. Restart the affected services or instances and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Ranger for the target cluster.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.