ALM-45001 Faulty HetuEngine Compute Instances
Alarm Description
The system checks the HetuEngine compute instance status every 60 seconds. This alarm is generated when the HetuEngine compute instance is faulty.
This alarm is cleared when all faulty HetuEngine compute instances are restored.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45001 |
Critical |
Quality of service |
HetuEngine |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
SQL tasks submitted to the faulty compute instance of HetuEngine fail to be executed.
Possible Causes
- The HDFS service is abnormal.
- The Yarn service is abnormal.
- Yarn queue resources are insufficient.
- The process of compute instances is faulty.
Handling Procedure
Check the HDFS service status.
- In the alarm list, check whether the "ALM-14000 HDFS Service Unavailable" alarm is generated.
- Clear "ALM-14000 HDFS Service Unavailable" according to the alarm help.
- In the alarm list, check whether this alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
Check the YARN service status.
- In the alarm list, check whether the "ALM-18000 YARN Service Unavailable" alarm is generated.
- Clear "ALM-18000 YARN Service Unavailable" according to the alarm help.
- In the alarm list, check whether this alarm is cleared.
- If yes, no further action is required.
- If no, go to 7.
Check the YARN queue resource status.
- In the alarm list, check whether the "ALM-18022 Insufficient YARN Queue Resources" alarm is generated.
- Clear "ALM-18022 Insufficient YARN Queue Resources" according to the alarm help.
- In the alarm list, check whether this alarm is cleared.
- If yes, no further action is required.
- If no, go to 10.
Check the HetuEngine compute instance status.
- Log in to FusionInsight Manager as an administrator who can access the HetuEngine web UI and choose Cluster > Services > HetuEngine.
- In the Basic Information area on the Dashboard tab page, click the link next to HSConsole WebUI to access the HSConsole page.
- On the compute instance page, check whether any compute instances are in the FAULT state.
- In the Operation column, click Start and wait until the instance is started.
- In the alarm list, check whether this alarm is cleared.
- If yes, no further action is required.
- If no, go to 15.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, select HetuEngine for the target cluster, and click OK.
- Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the hosts to which the role belongs, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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