ALM-25501 Too Many KerberosServer Requests
Alarm Description
The system checks the number of requests processed by the KerberosServer node every 30 seconds and compares the number with the threshold. This alarm is generated when the number of requests exceeds the threshold (10,000 by default) for multiple consecutive times (5 by default).
Its Trigger Count is configurable. If Trigger Count is set to 1, this alarm is cleared when the number of process connections is less than or equal to the threshold. If Trigger Count is greater than 1, this alarm is cleared when the number of requests is less than or equal to 90% of the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
25501 |
Major |
Quality of service |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
Additional Information |
Details |
Specifies alarm details. |
Impact on the System
KerberosServer responds slowly. As a result, Kerberos authentication times out and component services are in error.
Possible Causes
- There are too many KerberosServer requests.
- The alarm threshold or alarm trigger count is improperly configured.
Handling Procedure
Check whether there are too many KerberosServer requests.
- Log in to FusionInsight Manager and choose Cluster > Services > KrbServer to go to the KrbServer overview page.
- Observe the "Total KerberosServer Requests" chart and reduce the number of KerberosServer authentication requests based on the actual service scenario.
If no chart is available, click the drop-down arrow on the right, select Customize, select the desired item, and click OK.Figure 1 Total KerberosServer requests
- Wait about 2 minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
Check whether the alarm threshold or alarm trigger count is properly configured.
- On FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose KrbServer > Other > Total KerberosServer Requests, and check whether the alarm trigger count and alarm threshold are set properly.
- Change the trigger count and alarm threshold based on the actual number of requests, and apply the changes.
- Wait 2 minutes and check whether the alarm is automatically cleared.
- If yes, no further action is required.
- If no, go to 7.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select KrbServer for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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