ALM-23003 Loader Task Execution Failed
Alarm Description
This alarm is generated when the system detects that the Loader job fails. This alarm is cleared when the failed job is handled by a user. This alarm must be manually cleared.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
23003 |
Minor |
Quality of service |
Loader |
No |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Task ID |
Identifies the failed Loader job. |
JobName |
Specifies the name of the task that fails to be backed up. |
|
User Identification |
Specifies the name of the user who submits the Loader job. |
|
Details |
Specifies additional alarm information. |
Impact on the System
This is a job-level alarm for Loader. The job execution fails, and you need to view specific logs to locate the failure cause. No execution result is returned. After the fault is rectified, you need to execute the task again. No impact on the Loader service.
Possible Causes
- Task parameters are incorrectly configured.
- Exceptions occur when Yarn is executing a task.
Handling Procedure
Check whether task parameters are incorrectly configured.
- Log in to FusionInsight Manager and choose O&M > Alarm > Alarms. In the alarm list, open the drop-down list and view the alarm cause.
- If the alarm cause is Failed to submit the task, view the error details in Additional Information and view the execution records of the task on the Loader page.
By default, the admin user does not have the permissions to manage other components. If the page cannot be opened or the displayed content is incomplete when you access the native UI of a component due to insufficient permissions, you can manually create a user with the permissions to manage that component.
- Submit the task again.
- Check whether the task executed successfully.
Check whether exceptions occur when Yarn is executing a task.
- Log in to FusionInsight Manager. In the alarm list, open the drop-down list to view the alarm cause.
- Check Yarn activities. If the alarm cause is "Yarn execution failed", the Yarn activity is abnormal.
- Submit the task again.
- Check whether the task is executed successfully.
- In the alarm list, click Clear in the Operation column of the alarm to manually clear the alarm. No further action is required.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select the following services for the target cluster:
- DBService
- HDFS
- Loader
- MapReduce
- Yarn
- ZooKeeper
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
After the fault is rectified, the system does not automatically clear this alarm and you need to manually clear the alarm.
Related Information
None.
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