ALM-16003 Background Thread Usage Exceeds the Threshold
Alarm Description
The system checks the background thread usage in every 30 seconds. This alarm is generated when the usage of the background thread pool of Hive exceeds the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
16003 |
Critical (default threshold: 90%) Major (default threshold: 80%) |
Quality of service |
Hive |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Trigger condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
There are too many background threads, so the newly submitted task cannot run in time.
Possible Causes
- There are many tasks executed in the background thread pool of HiveServer.
- The capacity of the background thread pool of HiveServer is too small.
Handling Procedure
Check the number of tasks executed in the background thread pool of HiveServer.
- On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Hive. On the displayed page, click HiveServer Instance and check values of Background Thread Count and Background Thread Usage.
- Check whether the number of background threads in the latest half an hour is excessively high. (By default, the queue number is 100, and the thread number is considered as high if it is 90 or larger.)
- Adjust the number of tasks submitted to the background thread pool. (For example, cancel some time-consuming tasks with low performance.)
- Check whether the values of Background Thread Count and Background Thread Usage decrease.
Check the capacity of the HiveServer background thread pool.
- On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Hive. On the displayed page, click HiveServer Instance and check values of Background Thread Count and Background Thread Usage.
- Increase the value of hive.server2.async.exec.threads in the ${BIGDATA_HOME}/FusionInsight_HD_8.1.0.1/1_23_HiveServer/etc/hive-site.xml file. For example, increase the value by 20%.
- Save the modification.
- Check whether the alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 9.
Collect fault information.
- On the FusionInsight Manager portal, choose O&M > Log > Download.
- Select Hive in the required cluster from the Service.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot