Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-13007 Available ZooKeeper Client Connections Are Insufficient
Updated on 2024-11-29 GMT+08:00

ALM-13007 Available ZooKeeper Client Connections Are Insufficient

Alarm Description

The system periodically detects the number of active processes between the ZooKeeper client and the ZooKeeper server every 60 seconds. This alarm is generated when the number of connections exceeds the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

13007

Critical (default threshold: 2200)

Major (default threshold: 2000)

Minor (default threshold: 1800)

Quality of service

ZooKeeper

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service name for which the alarm is generated.

RoleName

Specifies the role name for which the alarm is generated.

HostName

Specifies the host name for which the alarm is generated.

Additional Information

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

A large number of processes are connected to ZooKeeper, and the number of ZooKeeper connections is used up. As a result, services of upstream components (such as Yarn, Flink, and Spark) are abnormal.

Possible Causes

A large number of client processes are connected to ZooKeeper. The thresholds are not appropriate.

Handling ProcedureHandling Procedure

Check whether there are a large number of client processes connected to ZooKeeper.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms. On the displayed interface, click the drop-down button of Available ZooKeeper Client Connections Are Insufficient. Confirm the node IP address of the host for which the alarm is generated in the Location Information.
  2. Open the ZooKeeper service interface, click Resource to enter the Resource page, and check whether the number of connections of the client with the IP address specified by Number of Connections (By Client IP Address) is large.

    • If it is, go to 3.
    • If it is not, go to 4.

  3. Check whether connection leakage occurs on the client process.
  4. Click in the Number of Connections (by Client IP Address) to enter the Thresholds page, and click Modify under Operation. Increase the threshold by referring to the value of maxClientCnxns by choosing Cluster > Name of the desired cluster > Services > ZooKeeper > Configurations > All Configurations > quorumpeer.
  5. Check whether the alarm is cleared.

    • If it is, no further action is required.
    • If it is not, go to 6.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. Select ZooKeeper in the required cluster from the Service.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M engineers and send the collected logs.

Alarm Clearance

After the fault is rectified, the system automatically clears this alarm.

Related Information

None.