Updated on 2024-11-29 GMT+08:00

SMS.0212 Agent Restarted

Symptom

During a Windows migration, the migration task was abnormal, and the error message "SMS.0212 Agent restarted" was displayed.

Possible Causes

Possible causes include:

  • The SMS-Agent program was manually restarted on the source server.
  • After the source system account was deregistered, the SMS-Agent program exited and then was started again.

Solutions

  • Solution 1
    1. In the server list on the SMS console, locate the source server record and choose More > Delete Target Configuration in the Operation column.
    2. Configure a target server and start the migration again.
  • Solution 2
    1. In the service list on the SMS console, locate the source server record and choose More > Delete in the Operation column. Then delete the server record.
    2. Log in to the source server, stop the SMS-Agent program, and run it again.

      If the SMS-Agent exits due to account deregistration, you are advised to use the SMS-Agent (Python 2) for the migration.

      • Windows Agent (Python 3): Double-click SMS-Agent.exe in the SMS-Agent-Py3 directory to restart the SMS-Agent.
      • Windows Agent (Python 2): Double-click restart.bat in the SMS-Agent-Py2 directory to restart the SMS-Agent.
    3. Enter the AK/SK pair for the Huawei Cloud account and the SMS domain name for the region you are migrating to.
    4. After the Agent is started, go to the SMS console and configure a target server again.