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User Guide
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Asynchronous Replication
- Managing a Replica Pair
- Managing a Protection Group
- Managing Protected Instances
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- Appendixes
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API Reference
- Before You Start
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SDRS APIs
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Protection Group
- Creating a Protection Group
- Querying Protection Groups
- Querying the Details of a Protection Group
- Deleting a Protection Group
- Changing the Name of a Protection Group
- Enabling Protection or Enabling Protection Again for a Protection Group
- Disabling Protection for a Protection Group
- Performing a Failover for a Protection Group
- Performing a Planned Failover for a Protection Group
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Protected Instance
- Creating a Protected Instance
- Deleting a Protected Instance
- Querying Protected Instances
- Querying Details About a Protected Instance
- Changing the Name of a Protected Instance
- Attaching a Replication Pair to a Protected Instance
- Detaching a Replication Pair from a Protected Instance
- Adding an NIC to a Protected Instance
- Deleting an NIC from a Protected Instance
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FAQs
- Common Problems
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Synchronous Replication (for Installed Base Operations)
- Do I Need to Manually Create DR Resources?
- What Can I Do When the EIP Cannot Be Pinged After I Perform a Switchover for a Protection Group Containing a SUSE Server?
- What Can I Do If the NIC Names of the DR Drill Server and Production Site Server Are Different?
- What Can I Do If hostname of the Production Site Server and DR Site Server Are Different After a Switchover or Failover?
- Why NICs of DR Site Servers Are Not Displayed After I Perform a Failover?
- What Are the Precautions If the Production Site Server Uses the Key Login Mode?
- What Should I Pay Attention to When Logging In to the Server After the First Time Ever I Executed a Switchover, Failover, or DR Drill?
- How Do I Use a Resource Package?
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Asynchronous Replication
- How Do I Handle the drm Process Start Failure?
- Failed to Install and Configure Disaster Recovery Gateway When Process drm Exists But Port 7443 Is Not Listened
- What Can I Do If the Name of a Production Site Server or the Host Name Reported by the Gateway Is Incorrect and Always Displayed as "localhost"?
- What Can I Do If the Disaster Recovery Site VM Is Not Started After a Switchover?
- How Do I Obtain the Installation Package on a Production Site Server from the Gateway?
- How Do I Enable or Disable an ECS Firewall and Add a Port Exception to the Firewall?
- Why Can't I Find the Disaster Recovery Gateway When Associating a Replica Pair with It?
- Why Is No Production Site Server Displayed When I Create Protected Instances?
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What Can I Do If hostname of the Production Site Server and DR Site Server Are Different After a Switchover or Failover?
Symptom
Users have changed hostname of the production site server before they perform a switchover or failover for the first time. After the switchover or failover, users start the DR site server and find that hostname of the DR site server is not updated accordingly.
Possible Causes
For Linux servers, if you have changed hostname of the production site server before you perform a switchover or failover for the first time, this modification will not synchronize to the DR site server.
Prerequisites
- The production site server is a Linux server with Cloud-Init installed.
- hostname of the production site server has been changed.
Solution 1 (If You Have Not Performed a Switchover or Failover)
Set preserve_hostname: false to preserve_hostname: true in the Cloud-Init configuration file /etc/cloud/cloud.cfg to ensure that hostname of the production site server and DR site server are the same after you enable protection.
The procedure is as follows:
- Log in to the production site server.
- Run the following command to edit the /etc/cloud/cloud.cfg configuration file:
sudo vim /etc/cloud/cloud.cfg
- Modify preserve_hostname.
- If preserve_hostname: false is already available in the /etc/cloud/cloud.cfg configuration file, change it to preserve_hostname: true.
- If preserve_hostname: false is unavailable in the /etc/cloud/cloud.cfg configuration file, add preserve_hostname: true before cloud_init_modules.
- Perform a switchover or failover.
After the switchover or failover, hostname of the DR site server and production site server are the same.
Solution 2 (If You Have Performed a Switchover or Failover)
If you have not modified configuration file /etc/cloud/cloud.cfg before the switchover or failover, log in to the DR site server and manually change hostname of the DR site server to that of the production site server.
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