Help Center/ Data Lake Insight/ FAQs/ Flink Jobs/ Flink Jar Jobs/ Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?
Updated on 2024-09-29 GMT+08:00

Why Is Error Message "Authentication failed" Displayed During Flink Jar Job Running?

Symptom

An exception occurred when a Flink Jar job is running. The following error information is displayed in the job log:
org.apache.flink.shaded.curator.org.apache.curator.ConnectionState - Authentication failed

Possible Causes

Service authorization is not configured for the account on the Global Configuration page. When the account is used to create a datasource connection to access external data, the access fails.

Solution

  1. Log in to the DLI management console. In the navigation pane on the left, choose Global Configuration > Service Authorization.
  2. On the agency settings page, select required permissions.

    DLI Datasource Connections Agency Access is the permissions to access and use VPCs, subnets, routes, and VPC peering connections in datasource scenarios.

    For more information, see DLI Agency Permissions.

  3. Select the permissions to be included in dli_management_agency and click Update.

    Figure 1 Updating agency permissions

  4. After updating the agency, recreate the datasource connection and rerun the job.