What Can I Do If a Query Error Is Reported After Data Is Written Into the DDS Cluster?
Symptom
Data is continuously written into the DDS cluster. After the data is written into the DDS cluster, an error is reported during query.
Example:
W SHARDING [Balancer] Failed to enforce tag ranges :: caused by :: ExceededTimeLimit: Unable to obtain shard utilization information for shard01 due to Operation timed out, request was RemoteCommand -- target: 192.168.*.*:8635, db: admin, cmd:{ getShardStatistics: 1, maxTimeMS: 30000 }
Possible Cause
Data is continuously written into the storage system, causing chunk splitting timeout in the background.
Solution
This is a normal warning error and does not affect operations. You can try again later.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot