Help Center/ Intelligent EdgeFabric/ Edgectl User Guide/ Error Codes/ OS Errors/ ERROR3401 Failed to resolve the domain name
Updated on 2024-09-05 GMT+08:00

ERROR3401 Failed to resolve the domain name

Description

edgectl failed to resolve the domain name.

Possible Causes

  • The domain name does not exist.
  • The DNS server is not configured on the node.
  • The node cannot connect to the DNS server.
  • The DNS server does not work.

Solution

To rectify the fault, perform the following steps:

  1. Check whether the domain name exists.

    Check whether the domain name can be resolved on the node where the domain name resolution service is normal. If the domain name cannot be resolved, change it to another domain name.

  2. Check whether the DNS server is configured on the node.

    On the node, open the /etc/resolv.conf file and check whether the DNS server is configured. If not, configure the DNS server. For example, add the following line about the IP address (114.114.114.114) of the DNS server on the public network to the /etc/resolv.conf file, and save the file.

    nameserver 114.114.114.114

  3. Check whether the node can connect to the DNS server.

    On the node, open the /etc/resolv.conf file, obtain the IP address of the DNS server, and ping the IP address.

    ping 114.114.114.114

  4. Check whether the DNS server works properly.

    If the DNS server does not work, replace the DNS server or contact the maintenance personnel of the DNS server to restore the DNS server.