Help Center/ Cloud Container Engine/ FAQs/ Storage/ What Should I Do If "target is busy" Is Displayed When a Pod with Cloud Storage Mounted Is Being Deleted?
Updated on 2024-09-04 GMT+08:00

What Should I Do If "target is busy" Is Displayed When a Pod with Cloud Storage Mounted Is Being Deleted?

Symptom

A pod remains in the terminating state when it is being deleted. When you get kubelet logs in the /var/log/cce/kubernetes/kubelet.log directory on the node where this pod runs, the following error message is displayed:

...unmount failed: exit status 32...Output: umount: <mount-path>: target is busy

Possible Causes

Other processes on the node are using the cloud storage device.

Solution

Log in to the node where the faulty pod runs, search for the process that is using the device, and stop that process.

  1. Log in to the node where the faulty pod runs.
  2. Run the following command to find the cloud storage device in the corresponding mount path: ( <mount-path> specifies the mount path displayed in the error message.)

    mount | grep <mount-path>

    Information similar to the following is displayed:

    /dev/sdatest on <mount-path> type ext4 (rw,relatime)

  3. Run the following command to find the ID of the process that uses the block storage:

    fuser -mv /dev/sdatest

  4. Stop the process.

    fuser -kmv /dev/sdatest

    After the process is stopped, the cloud storage device is automatically uninstalled and the pod is deleted.