ALM-29100 Kudu Service Unavailable
Alarm Description
The system checks the Kudu service status every 60 seconds. This alarm is generated when the system detects that all Kudu instances are abnormal and considers that the Kudu service is unavailable.
This alarm is cleared when at least one Kudu instance becomes normal and the system considers that the Kudu instance service is restored.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
29100 |
Critical |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
Impact on the System
Users cannot use the Kudu service.
Possible Causes
Some Kudu instances are abnormal.
Handling Procedure
Handle the Kudu instance exceptions.
- On FusionInsight Manager, choose O&M > Alarm > Alarms. On the displayed page, locate the alarm ALM-29100 Kudu Service Unavailable.
- In the Location Information column, record the host name and role name.
- Choose Cluster > Services > Kudu > Instances. Click the role name for the host name obtained in 2, view the instance logs, and restore the instance. Then, check whether the alarm is cleared.
- Choose O&M > Alarm > Alarms and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
Collect the fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Expand the Service drop-down list, and select Kudu for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
After the fault that triggers the alarm is rectified, the alarm is automatically cleared.
Related Information
None
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